Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 29, 2026 - 00:00 GMT+08:00
Scheduled
We will be performing scheduled maintenance on Thursday, 29 January 2026, from 12:00AM to 01:00 AM. During this time, all services may be affected. Hereโs what to expect:
๐ Be U app will be temporarily unavailable
We appreciate your understanding as we enhance your experience โจ Thank you!
Posted Jan 28, 2026 - 15:16 GMT+08:00
This scheduled maintenance affected: ๐ฑ Be U App, ๐คณ DuitNow QR & Fund Transfers, ๐ฒ Be U Fund Transfer, ๐ธ Bank Islam Fund Transfer, ๐ณ Debit Card-i Services, ๐ ๏ธ Debit Card-i Self-service Management, and ๐ JomPAY.