Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 22, 2026 - 01:00 GMT+08:00
Scheduled
We will be performing scheduled maintenance on Thursday, 22 January 2026, from 01:00AM to 05:30 AM. During this time, some services may be affected. Here’s what to expect:
📌 DuitNow, DuitNow QR and JomPAY will be temporarily unavailable
We appreciate your understanding as we enhance your experience ✨ Thank you!
Posted Jan 21, 2026 - 16:03 GMT+08:00
This scheduled maintenance affected: 🤳 DuitNow QR & Fund Transfers and 📃 JomPAY.