Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 18, 2025 - 23:00 GMT+08:00
Scheduled
Weโre upgrading Be U this Friday & Saturday, 18โ19 July 2025. Some services may be unavailable โ hereโs what to expect:
๐ 18/07, 11:00PMโ01:00AM โ You might not be able to access Be U. ๐ 19/07, 12:00AMโ06:00AM โ DuitNow, DuitNow QR & JomPay will be temporarily unavailable.
We appreciate your understanding while we enhance your experience โจ Thank you!
Posted Jul 18, 2025 - 17:59 GMT+08:00
This scheduled maintenance affected: ๐ฑ Be U App, ๐คณ DuitNow QR & Fund Transfers, ๐ฒ Be U Fund Transfer, ๐ธ Bank Islam Fund Transfer, ๐ณ Debit Card-i Services, ๐ ๏ธ Debit Card-i Self-service Management, and ๐ JomPAY.